store | blogs | forums | twitter | facebook | wiki | mailing lists | downloads | support portal
Atomic Secure Linux
It is currently Thu Apr 24, 2014 2:42 pm

» Feed - Atomicorp

All times are UTC - 5 hours [ DST ]




Post new topic Reply to topic  [ 6 posts ] 
Author Message
 Post subject: open of auto-whitelist file failed
Unread postPosted: Tue Feb 01, 2011 7:07 pm 
Offline
Forum Regular
Forum Regular

Joined: Wed Aug 04, 2010 2:52 pm
Posts: 257
Getting tons of these:

Code:
OSSEC HIDS Notification.
2011 Feb 01 17:13:26

Received From: server1->/var/log/psa/maillog
Rule: 1002 fired (level 2) -> "Unknown problem somewhere in the system."
Portion of the log(s):

Feb  1 14:13:24 server1 spamd[1720]: auto-whitelist: open of auto-whitelist file failed: locker: safe_lock: cannot create tmp lockfile /var/qmail/mailnames///.spamassassin/auto-whitelist.lock.server1.premierhosting.net.1720 for /var/qmail/mailnames///.spamassassin/auto-whitelist.lock: No such file or directory

 --END OF NOTIFICATION


I didn't edit this, it appears to not include a domain or user account in the error, which would explain why the file is hard to open. I could just create the file and give it perms, but it seems like there must be a deeper problem here.

I've been searching google and these forums and found a few mentions, but nothing that I could actually do to fix it :)

Any ideas?


Top
 Profile  
 
 Post subject: Re: open of auto-whitelist file failed
Unread postPosted: Tue Feb 01, 2011 11:12 pm 
Offline
Atomicorp Staff - Site Admin
Atomicorp Staff - Site Admin

Joined: Wed Dec 31, 1969 8:00 pm
Posts: 7780
Location: earth
make the directory and/or make it writable by the user trying to write to it


Top
 Profile  
 
 Post subject: Re: open of auto-whitelist file failed
Unread postPosted: Wed Feb 02, 2011 12:37 am 
Offline
Forum Regular
Forum Regular

Joined: Wed Aug 04, 2010 2:52 pm
Posts: 257
OK, so I created a dir here: /var/qmail/mailnames/.spamassassin

We'll see if that fixes it.


Top
 Profile  
 
 Post subject: Re: open of auto-whitelist file failed
Unread postPosted: Wed Mar 16, 2011 12:38 am 
Offline
New Forum User
New Forum User

Joined: Wed Mar 16, 2011 12:34 am
Posts: 2
Location: Minnesota
did that fix it?


Top
 Profile  
 
 Post subject: Re: open of auto-whitelist file failed
Unread postPosted: Wed Mar 16, 2011 8:57 am 
Offline
Long Time Forum Regular
Long Time Forum Regular

Joined: Thu Dec 09, 2004 11:19 am
Posts: 2007
Are you using 4PSA's SpamGuardian by any chance?

_________________
--------------------------------
<advert>
If you want to rent a UK-based VPS that comes with friendly advice and support from a fellow ART fan, please get in touch.
</advert>


Top
 Profile  
 
 Post subject: Re: open of auto-whitelist file failed
Unread postPosted: Wed Mar 16, 2011 2:43 pm 
Offline
Forum Regular
Forum Regular

Joined: Wed Aug 04, 2010 2:52 pm
Posts: 257
I think it fixed it, as I haven't been seeing the message. However I just checked and the .spamassassin folder is missing, but a .spamtrain folder is now there.


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 6 posts ] 

» Feed - Atomicorp

All times are UTC - 5 hours [ DST ]


Who is online

Users browsing this forum: No registered users and 4 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group