store | blogs | forums | twitter | facebook | wiki | mailing lists | downloads | support portal
Atomic Secure Linux
It is currently Sat Apr 19, 2014 3:02 am

» Feed - Atomicorp

All times are UTC - 5 hours [ DST ]




Post new topic Reply to topic  [ 1 post ] 
Author Message
 Post subject: install a specific php version through yum
Unread postPosted: Wed Oct 26, 2011 1:29 pm 
Offline
New Forum User
New Forum User

Joined: Tue Sep 26, 2006 9:44 am
Posts: 2
First of all, great repository!!!

I have php-5.1.6-27.el5_5.3 installed on a "fresh server" and I need php-5.2.17-1.el5.art

When I do a yum update php it will update to the latest php-5.3.8-1, but I really need php-5.2.17-1.el5.art.

If I read various posts on forums, I should use the full version name, ie:

yum --enablerepo=art update php-5.2.17-1.el5.art

But when running this command it still goes to php-5.3.8-1 becauses of certain dependencies:

Resolving Dependencies
--> Running transaction check
--> Processing Dependency: php = 5.1.6-27.el5_5.3 for package: php-devel
---> Package php.x86_64 0:5.2.17-1.el5.art set to be updated
--> Processing Dependency: php-common = 5.2.17-1.el5.art for package: php
--> Processing Dependency: php-cli = 5.2.17-1.el5.art for package: php
--> Running transaction check
---> Package php-cli.x86_64 0:5.2.17-1.el5.art set to be updated
--> Processing Dependency: php-common = 5.1.6-27.el5_5.3 for package: php-odbc
--> Processing Dependency: php-common = 5.1.6-27.el5_5.3 for package: php-mbstring
--> Processing Dependency: php-common = 5.1.6-27.el5_5.3 for package: php-gd
--> Processing Dependency: php-common = 5.1.6-27.el5_5.3 for package: php-mysql
--> Processing Dependency: php-common = 5.1.6-27.el5_5.3 for package: php-pdo
--> Processing Dependency: php-common = 5.1.6-27.el5_5.3 for package: php-ldap
--> Processing Dependency: php-common = 5.1.6-27.el5_5.3 for package: php-xmlrpc
--> Processing Dependency: php-common = 5.1.6-27.el5_5.3 for package: php-snmp
--> Processing Dependency: php-common = 5.1.6-27.el5_5.3 for package: php-imap
--> Processing Dependency: php-common = 5.1.6-27.el5_5.3 for package: php-pgsql
---> Package php-common.x86_64 0:5.2.17-1.el5.art set to be updated
---> Package php-devel.x86_64 0:5.3.8-1.el5.art set to be updated
--> Processing Dependency: php = 5.3.8-1.el5.art for package: php-devel
--> Running transaction check
---> Package php.x86_64 0:5.2.17-1.el5.art set to be updated
---> Package php.x86_64 0:5.3.8-1.el5.art set to be updated
--> Processing Dependency: php-cli = 5.3.8-1.el5.art for package: php
--> Processing Dependency: php-common = 5.3.8-1.el5.art for package: php
---> Package php-gd.x86_64 0:5.3.8-1.el5.art set to be updated
--> Processing Dependency: libt1.so.5()(64bit) for package: php-gd
---> Package php-imap.x86_64 0:5.3.8-1.el5.art set to be updated
---> Package php-ldap.x86_64 0:5.3.8-1.el5.art set to be updated
---> Package php-mbstring.x86_64 0:5.3.8-1.el5.art set to be updated
---> Package php-mysql.x86_64 0:5.3.8-1.el5.art set to be updated
--> Processing Dependency: libmysqlclient.so.16(libmysqlclient_16)(64bit) for package: php-mysql
--> Processing Dependency: libmysqlclient.so.16()(64bit) for package: php-mysql
---> Package php-odbc.x86_64 0:5.3.8-1.el5.art set to be updated
---> Package php-pdo.x86_64 0:5.3.8-1.el5.art set to be updated
---> Package php-pgsql.x86_64 0:5.3.8-1.el5.art set to be updated
---> Package php-snmp.x86_64 0:5.3.8-1.el5.art set to be updated
---> Package php-xmlrpc.x86_64 0:5.3.8-1.el5.art set to be updated
--> Running transaction check
---> Package mysqlclient16.x86_64 0:5.1.59-1.el5.art set to be updated
---> Package php-cli.x86_64 0:5.2.17-1.el5.art set to be updated
---> Package php-cli.x86_64 0:5.3.8-1.el5.art set to be updated
--> Processing Dependency: libedit.so.0()(64bit) for package: php-cli
---> Package php-common.x86_64 0:5.2.17-1.el5.art set to be updated
---> Package php-common.x86_64 0:5.3.8-1.el5.art set to be updated
---> Package t1lib.x86_64 0:5.1.2-2.el5.art set to be updated
--> Processing Dependency: libXaw.so.7()(64bit) for package: t1lib
--> Processing Dependency: libXt.so.6()(64bit) for package: t1lib
--> Running transaction check
---> Package libXaw.x86_64 0:1.0.2-8.1 set to be updated
--> Processing Dependency: libXmu.so.6()(64bit) for package: libXaw
---> Package libXt.x86_64 0:1.0.2-3.2.el5 set to be updated
--> Processing Dependency: libICE.so.6()(64bit) for package: libXt
--> Processing Dependency: libSM.so.6()(64bit) for package: libXt
---> Package libedit.x86_64 0:3.0-2.20090923cvs.el5.art set to be updated
--> Running transaction check
---> Package libICE.x86_64 0:1.0.1-2.1 set to be updated
---> Package libSM.x86_64 0:1.0.1-3.1 set to be updated
---> Package libXmu.x86_64 0:1.0.2-5 set to be updated

====================================================================================================================================
Package Arch Version Repository Size
====================================================================================================================================
Installing for dependencies:
libICE x86_64 1.0.1-2.1 sb-base 54 k
libSM x86_64 1.0.1-3.1 sb-base 28 k
libXaw x86_64 1.0.2-8.1 sb-base 329 k
libXmu x86_64 1.0.2-5 sb-base 63 k
libXt x86_64 1.0.2-3.2.el5 sb-base 181 k
libedit x86_64 3.0-2.20090923cvs.el5.art sb-art 81 k
mysqlclient16 x86_64 5.1.59-1.el5.art sb-art 1.8 M
t1lib x86_64 5.1.2-2.el5.art sb-art 208 k
Updating for dependencies:
php x86_64 5.3.8-1.el5.art sb-art 1.4 M
php-cli x86_64 5.3.8-1.el5.art sb-art 2.6 M
php-common x86_64 5.3.8-1.el5.art sb-art 982 k
php-devel x86_64 5.3.8-1.el5.art sb-art 625 k
php-gd x86_64 5.3.8-1.el5.art sb-art 208 k
php-imap x86_64 5.3.8-1.el5.art sb-art 87 k
php-ldap x86_64 5.3.8-1.el5.art sb-art 56 k
php-mbstring x86_64 5.3.8-1.el5.art sb-art 2.3 M
php-mysql x86_64 5.3.8-1.el5.art sb-art 160 k
php-odbc x86_64 5.3.8-1.el5.art sb-art 87 k
php-pdo x86_64 5.3.8-1.el5.art sb-art 117 k
php-pgsql x86_64 5.3.8-1.el5.art sb-art 134 k
php-snmp x86_64 5.3.8-1.el5.art sb-art 40 k
php-xmlrpc x86_64 5.3.8-1.el5.art sb-art 86 k

Is there a way to get version 5.2.17-1.el5.art on my server? I tried to exlude php-5.3.8-1.el5, but that didn't work either for me.

Hope someone can help me out.

Regards, Gijsbert


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 1 post ] 

» Feed - Atomicorp

All times are UTC - 5 hours [ DST ]


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group