store | blogs | forums | twitter | facebook | wiki | downloads | support portal
Atomic Secure Linux
It is currently Tue Sep 02, 2014 9:55 am

» Feed - Atomicorp

All times are UTC - 5 hours [ DST ]




Post new topic Reply to topic  [ 6 posts ] 
Author Message
 Post subject: rkhunter 1.2.9 install problem
Unread postPosted: Tue Oct 03, 2006 7:07 pm 
Offline
Forum User
Forum User

Joined: Thu Jul 06, 2006 4:18 pm
Posts: 17
I attempted to install rkhunter 1.2.9

Quote:
yum install rkhunter
Error: Cannot find baseurl or name for server 'psa-7.5'. Skipping
Gathering header information file(s) from server(s)
Server: Atomic Rocket Turtle - 9 - Atomic PSA-Compatible RPMS
Server: Red Hat Linux 9 base
Server: Fedora Legacy utilities for Red Hat Linux 9
Server: Red Hat Linux 9 updates
Finding updated packages
Downloading needed headers
Resolving dependencies
.....Unable to satisfy dependencies
Package prelink needs kernel >= 2.4.10, this is not available.


But my kernel is above this:

Quote:
uname -r
2.6.9-022stab078.20-enterprise


Just FYI, my system is a VPS running Plesk 7.5.4 on RH9 under VZ3.


Top
 Profile  
 
 Post subject:
Unread postPosted: Wed Oct 04, 2006 6:19 am 
Offline
Atomicorp Staff - Site Admin
Atomicorp Staff - Site Admin

Joined: Wed Dec 31, 1969 8:00 pm
Posts: 7892
Location: earth
looks like your yum config is mangled, can you paste it?


Top
 Profile  
 
 Post subject:
Unread postPosted: Wed Oct 04, 2006 7:40 am 
Offline
Forum User
Forum User

Joined: Thu Jul 06, 2006 4:18 pm
Posts: 17
Here it is:

Quote:
[main]
cachedir=/var/cache/yum
debuglevel=2
logfile=/var/log/yum.log
pkgpolicy=newest
distroverpkg=redhat-release
tolerant=1
exactarch=1
#exclude=spamassassin* kernel* iptables*
exclude=spamassassin* e2fsprogs* kernel* iptables* fetchmail*

# Redhat 7.2, 7.3, 8.0, and 9.0 users ONLY
[base]
name=Red Hat Linux $releasever base
baseurl=http://download.fedoralegacy.org/redhat/$releasever/os/$basearch

# Redhat 7.2, 7.3, 8.0, and 9.0 users ONLY
[updates]
name=Red Hat Linux $releasever updates
baseurl=http://download.fedoralegacy.org/redhat/$releasever/updates/$basearch
exclude=kernel*

# Redhat 7.2, 7.3, 8.0, and 9.0 users ONLY
[legacy-utils]
name=Fedora Legacy utilities for Red Hat Linux $releasever
baseurl=http://download.fedoralegacy.org/redhat/$releasever/legacy-utils/$basearch

# THIS CHANNEL CONTAINS MY PSA COMPATIBLE RPMS (php, mysql, qmail-scanner, etc)
[atomic]
name=Atomic Rocket Turtle - $releasever - Atomic PSA-Compatible RPMS
baseurl=http://3es.atomicrocketturtle.com/atomic/art/$releasever/
#baseurl=http://www.atomicrocketturtle.com/atomic/art/$releasever/

[psa-7.5]
#name=Atomic Rocket Turtle - $releasever - SW-Soft PSA 7.5 RPMS
#baseurl=http://3es.atomicrocketturtle.com/atomic/psa-7.5/$releasever/
##baseurl=http://www.atomicrocketturtle.com/atomic/psa-7.5/$releasever/


I have the [psa-7.5] on commented out right now because your directory structure on the server is missing it.


Top
 Profile  
 
 Post subject:
Unread postPosted: Wed Oct 04, 2006 10:20 am 
Offline
Atomicorp Staff - Site Admin
Atomicorp Staff - Site Admin

Joined: Wed Dec 31, 1969 8:00 pm
Posts: 7892
Location: earth
Youve got to comment out [psa-7.5] as well


Top
 Profile  
 
 Post subject:
Unread postPosted: Wed Oct 04, 2006 10:25 am 
Offline
Forum User
Forum User

Joined: Thu Jul 06, 2006 4:18 pm
Posts: 17
scott wrote:
Youve got to comment out [psa-7.5] as well


I have done that now, but the error message I get while installing rkhunter is the same.

Thanks.


Top
 Profile  
 
 Post subject:
Unread postPosted: Wed Oct 04, 2006 12:03 pm 
Offline
Atomicorp Staff - Site Admin
Atomicorp Staff - Site Admin

Joined: Wed Dec 31, 1969 8:00 pm
Posts: 7892
Location: earth
Ah, its because you're on a VPS. You dont have the kernel rpm, and they've modified the base OS to get around that. You're on your own as far as resolving that, I can't at this time support the modified OS's.


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 6 posts ] 

» Feed - Atomicorp

All times are UTC - 5 hours [ DST ]


Who is online

Users browsing this forum: No registered users and 7 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group