store | blogs | forums | twitter | facebook | wiki | downloads | support portal
Atomic Secure Linux
It is currently Thu Sep 18, 2014 7:38 am

» Feed - Atomicorp

All times are UTC - 5 hours [ DST ]




Post new topic Reply to topic  [ 4 posts ] 
Author Message
 Post subject: php 5.3 - plesk 10.1 - fastcgi - safe mode
Unread postPosted: Sun Oct 02, 2011 12:49 pm 
Offline
Forum Regular
Forum Regular

Joined: Sun Mar 29, 2009 6:52 pm
Posts: 350
Hi guys.

We know that php 5.3 does not support safemode anymore as it has been depriciated.

php 5.2 on the other hand is no longer supported ...

Finally fastcgi breaks sites. Especially joomla. It will never work with fastcgi.

So how do you actually isolate sites if you are using php 5.3 and you are using php as an apache module ?
This has been worrying me over the last few days ...

Regards

_________________
Hello IT.
Phone : Blah Blah ....
Have you tried turning it on and off again ?
Phone : Blah Blah ....
....
I'm sorry, are you from the Past ?!
http://www.youtube.com/watch?v=-E4fm4Wqego


Top
 Profile  
 
 Post subject: Re: php 5.3 - plesk 10.1 - fastcgi - safe mode
Unread postPosted: Sun Oct 09, 2011 10:04 am 
Offline
Atomicorp Staff - Site Admin
Atomicorp Staff - Site Admin

Joined: Wed Dec 31, 1969 8:00 pm
Posts: 7899
Location: earth
Actually it does still support safe_mode, it just says it will be deprecated soon.


Top
 Profile  
 
 Post subject: Re: php 5.3 - plesk 10.1 - fastcgi - safe mode
Unread postPosted: Sun Oct 09, 2011 10:14 am 
Offline
Forum Regular
Forum Regular

Joined: Sun Mar 29, 2009 6:52 pm
Posts: 350
scott wrote:
Actually it does still support safe_mode, it just says it will be deprecated soon.


Oh. So on 5.3 safe mode is still working ?
But on the apache error log it says about safe mode that it has been depreciated.

_________________
Hello IT.
Phone : Blah Blah ....
Have you tried turning it on and off again ?
Phone : Blah Blah ....
....
I'm sorry, are you from the Past ?!
http://www.youtube.com/watch?v=-E4fm4Wqego


Top
 Profile  
 
 Post subject: Re: php 5.3 - plesk 10.1 - fastcgi - safe mode
Unread postPosted: Sun Oct 09, 2011 2:16 pm 
Offline
Long Time Forum Regular
Long Time Forum Regular

Joined: Sat Aug 20, 2005 9:30 am
Posts: 2812
Location: The Netherlands
Safe mode is deprecated, but that doesn't mean it doesn't work anymore. The feature is currently still there in PHP 5.3. Language developers usually mark a feature as deprecated when they want application developers to stop using it and it also signals that the feature might be removed in some future version. But for now it's still there, you'll just get a warning that it's deprecated.

http://en.wikipedia.org/wiki/Deprecation

_________________
Lemonbit Internet Dedicated Server Management


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 4 posts ] 

» Feed - Atomicorp

All times are UTC - 5 hours [ DST ]


Who is online

Users browsing this forum: Baidu [Spider] and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group