store | blogs | forums | twitter | facebook | wiki | downloads | support portal
Atomic Secure Linux
It is currently Fri Oct 31, 2014 12:00 am

» Feed - Atomicorp

All times are UTC - 5 hours [ DST ]




Post new topic Reply to topic  [ 3 posts ] 
Author Message
 Post subject: exim + php mail function, wrong return path
Unread postPosted: Tue Oct 18, 2011 7:23 am 
Offline
Forum Regular
Forum Regular

Joined: Sun Mar 29, 2009 6:52 pm
Posts: 350
Hey guys.

I have a joomla site which has the following issue.
When an email is sent from the joomla mail form the recipient sees Return-Path: <apache@server.hostname.com>.
Now I have the feeling this has to do with the box and not with joomla since this doesn't happen in another box.

I've found many describing the same issue but still haven't found a solution to it. Has anyone encountered the same issue ?

Thanks

_________________
Hello IT.
Phone : Blah Blah ....
Have you tried turning it on and off again ?
Phone : Blah Blah ....
....
I'm sorry, are you from the Past ?!
http://www.youtube.com/watch?v=-E4fm4Wqego


Top
 Profile  
 
 Post subject: Re: exim + php mail function, wrong return path
Unread postPosted: Tue Oct 18, 2011 2:37 pm 
Offline
Long Time Forum Regular
Long Time Forum Regular

Joined: Thu Dec 09, 2004 11:19 am
Posts: 2094
in php.ini:

Code:
sendmail_path = /usr/sbin/sendmail -t -i -f address@domain.tld


You can also add it to a vhost.conf (php_admin_value)

However, if the script uses its own smtp server/connects directly to a socket, then this won't make any difference. In such cases there would always be an option to change who the email is from.

Faris.

_________________
--------------------------------
<advert>
If you want to rent a UK-based VPS that comes with friendly advice and support from a fellow ART fan, please get in touch.
</advert>


Top
 Profile  
 
 Post subject: Re: exim + php mail function, wrong return path
Unread postPosted: Tue Oct 18, 2011 3:12 pm 
Offline
Forum Regular
Forum Regular

Joined: Sun Mar 29, 2009 6:52 pm
Posts: 350
faris wrote:
in php.ini:

Code:
sendmail_path = /usr/sbin/sendmail -t -i -f address@domain.tld


You can also add it to a vhost.conf (php_admin_value)

However, if the script uses its own smtp server/connects directly to a socket, then this won't make any difference. In such cases there would always be an option to change who the email is from.

Faris.



Ok after lots of hours and a lot of nerves I found out how to solve the issue.

Both -f address@domain.tld and (php_admin_value) did not solvethe problem !
Neither around 20 other workarounds I found on the net.

So I removed exim and I installed postfix.

It worked right away like a charm with the -f flag and the email set to it.
Did some testing and up to know it works perfectly.

Postfix is legendary. :)

_________________
Hello IT.
Phone : Blah Blah ....
Have you tried turning it on and off again ?
Phone : Blah Blah ....
....
I'm sorry, are you from the Past ?!
http://www.youtube.com/watch?v=-E4fm4Wqego


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 3 posts ] 

» Feed - Atomicorp

All times are UTC - 5 hours [ DST ]


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group