store | blogs | forums | twitter | facebook | wiki | downloads | support portal
Atomic Secure Linux
It is currently Tue Sep 30, 2014 3:51 pm

» Feed - Atomicorp

All times are UTC - 5 hours [ DST ]




Post new topic Reply to topic  [ 3 posts ] 
Author Message
 Post subject: PHP 5.3.6 mysql connection error
Unread postPosted: Mon May 16, 2011 1:36 pm 
Offline
Forum User
Forum User

Joined: Sun May 16, 2010 6:59 pm
Posts: 13
Hi,

Installed 5.3.6 and everything seemed to be working fine but this morning noticed mysql databases including Horde are not working.

php -v outputs:


# php -v
PHP Warning: PHP Startup: Unable to load dynamic library '/usr/lib64/php/modules/mysql.so' - /usr/lib64/php/modules/mysql.so: undefined symbol: PL_memory_wrap in Unknown on line 0
PHP 5.3.6 (cli) (built: Apr 19 2011 13:21:12)
Copyright (c) 1997-2011 The PHP Group
Zend Engine v2.3.0, Copyright (c) 1998-2011 Zend Technologies
with the ionCube PHP Loader v4.0.5, Copyright (c) 2002-2011, by ionCube Ltd.
with Suhosin v0.9.32.1, Copyright (c) 2007-2010, by SektionEins GmbH


Tried to roll back to 5.2 unsuccessfully, this is the output:

rpm -Uvh --force php-5.2.17-1.el5.art.x86_64.rpm php-common-5.2.17-1.el5.art.x86_64.rpm php-cli-5.2.17-1.el5.art.x86_64.rpm
error: Failed dependencies:
php-cli = 5.3.6-3.el5.art is needed by (installed) php-5.3.6-3.el5.art.i386

Please advice, my customers are trying to kill me....


Top
 Profile  
 
 Post subject: Re: PHP 5.3.6 mysql connection error
Unread postPosted: Mon May 16, 2011 2:42 pm 
Offline
Atomicorp Staff - Site Admin
Atomicorp Staff - Site Admin
User avatar

Joined: Thu Feb 07, 2008 7:49 pm
Posts: 3636
Location: Chantilly, VA
You need to use --oldpackage switch:

rpm -Uvh --oldpackage foo-1-1.i386.rpm

https://www.atomicorp.com/wiki/index.php/Rollback

_________________
Michael Shinn
Atomicorp - Security For Everyone

Co-Author of Troubleshooting Linux Firewalls.


Top
 Profile  
 
 Post subject: Re: PHP 5.3.6 mysql connection error
Unread postPosted: Mon May 16, 2011 2:57 pm 
Offline
Forum User
Forum User

Joined: Sun May 16, 2010 6:59 pm
Posts: 13
thanks for the input.
forgot to mention I had tried that already:


# rpm -Uvh --oldpackage php*.rpm
warning: package php-cli = 5.2.17-1.el5.art was already added, replacing with php-cli >= 5.3.6-3.el5.art
error: Failed dependencies:
php-cli = 5.2.17-1.el5.art is needed by php-5.2.17-1.el5.art.x86_64
libedit.so.0 is needed by php-cli-5.3.6-3.el5.art.i386


That's why I came with the 'force' instruction which was also unsuccessful.

Any idea??

Thanks again,


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 3 posts ] 

» Feed - Atomicorp

All times are UTC - 5 hours [ DST ]


Who is online

Users browsing this forum: Yahoo [Bot] and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group