store | blogs | forums | twitter | facebook | wiki | downloads | support portal
Atomic Secure Linux
It is currently Mon Dec 22, 2014 1:34 am

» Feed - Atomicorp

All times are UTC - 5 hours [ DST ]




Post new topic Reply to topic  [ 7 posts ] 
Author Message
 Post subject: PHP 5.3 requires MySQL 5.1?
Unread postPosted: Sun May 22, 2011 6:13 am 
Offline
Long Time Forum Regular
Long Time Forum Regular

Joined: Sat Aug 20, 2005 9:30 am
Posts: 2812
Location: The Netherlands
The situation: a CentOS 5.6 x86_64 server with stock MySQL server 5.0.77 installed and MySQL packages excluded in /etc/yum.repos.d/atomic.repo. PHP is currently 5.2.17. Trying to upgrade to PHP 5.3.6 yum can't resolve php-mysql's dependency on libmysqlclient.so.16:

Quote:
--> Running transaction check
---> Package php.x86_64 0:5.3.6-3.el5.art set to be updated
---> Package php-cli.x86_64 0:5.3.6-3.el5.art set to be updated
--> Processing Dependency: libedit.so.0()(64bit) for package: php-cli
---> Package php-common.x86_64 0:5.3.6-3.el5.art set to be updated
---> Package php-devel.x86_64 0:5.3.6-3.el5.art set to be updated
---> Package php-eaccelerator.x86_64 1:5.3.6_0.9.6.1-1.el5.art set to be updated
---> Package php-gd.x86_64 0:5.3.6-3.el5.art set to be updated
---> Package php-imap.x86_64 0:5.3.6-3.el5.art set to be updated
---> Package php-mbstring.x86_64 0:5.3.6-3.el5.art set to be updated
---> Package php-mcrypt.x86_64 0:5.3.6-3.el5.art set to be updated
---> Package php-mysql.x86_64 0:5.3.6-3.el5.art set to be updated
--> Processing Dependency: libmysqlclient.so.16(libmysqlclient_16)(64bit) for package: php-mysql
--> Processing Dependency: libmysqlclient.so.16()(64bit) for package: php-mysql
---> Package php-pdo.x86_64 0:5.3.6-3.el5.art set to be updated
---> Package php-soap.x86_64 0:5.3.6-3.el5.art set to be updated
---> Package php-xml.x86_64 0:5.3.6-3.el5.art set to be updated
--> Running transaction check
---> Package libedit.x86_64 0:3.0-2.20090923cvs.el5.art set to be updated
---> Package php-mysql.x86_64 0:5.3.6-3.el5.art set to be updated
--> Processing Dependency: libmysqlclient.so.16(libmysqlclient_16)(64bit) for package: php-mysql
--> Processing Dependency: libmysqlclient.so.16()(64bit) for package: php-mysql
--> Finished Dependency Resolution
php-mysql-5.3.6-3.el5.art.x86_64 from atomic has depsolving problems
--> Missing Dependency: libmysqlclient.so.16()(64bit) is needed by package php-mysql-5.3.6-3.el5.art.x86_64 (atomic)
php-mysql-5.3.6-3.el5.art.x86_64 from atomic has depsolving problems
--> Missing Dependency: libmysqlclient.so.16(libmysqlclient_16)(64bit) is needed by package php-mysql-5.3.6-3.el5.art.x86_64 (atomic)
Error: Missing Dependency: libmysqlclient.so.16(libmysqlclient_16)(64bit) is needed by package php-mysql-5.3.6-3.el5.art.x86_64 (atomic)
Error: Missing Dependency: libmysqlclient.so.16()(64bit) is needed by package php-mysql-5.3.6-3.el5.art.x86_64 (atomic)


AFAIK libmysqlclient.so.16 is part MySQL 5.1. Does PHP 5.3.6 really require libmysqlclient.so.16 and thus MySQL 5.1 or could php-mysql be built to work with MySQL 5.0's libmysqlclient.so.15?

_________________
Lemonbit Internet Dedicated Server Management


Top
 Profile  
 
 Post subject: Re: PHP 5.3 requires MySQL 5.1?
Unread postPosted: Sun May 22, 2011 10:22 am 
Offline
Atomicorp Staff - Site Admin
Atomicorp Staff - Site Admin

Joined: Wed Dec 31, 1969 8:00 pm
Posts: 7964
Location: earth
Yes, there is a mysqlclient16 package that would resolve that. The problem is your exclude is blocking it.


Top
 Profile  
 
 Post subject: Re: PHP 5.3 requires MySQL 5.1?
Unread postPosted: Sun May 22, 2011 1:59 pm 
Offline
Long Time Forum Regular
Long Time Forum Regular

Joined: Sat Aug 20, 2005 9:30 am
Posts: 2812
Location: The Netherlands
Ah, got it, thanks.

_________________
Lemonbit Internet Dedicated Server Management


Top
 Profile  
 
 Post subject: Re: PHP 5.3 requires MySQL 5.1?
Unread postPosted: Mon Oct 24, 2011 10:57 am 
Offline
New Forum User
New Forum User

Joined: Wed Oct 12, 2011 4:06 pm
Posts: 3
Location: Netherlands
Can you please pop-up a quick little howto what to do in this case?

I have MySQL 5.0.77 with PHP 5.1.6 on a stock CentOS / Plesk 9.5 installation.

And I need only PHP to upgrade to 5.2.17 or 5.3.*

I also have mysql* excluded in the atomic.repo

What do I need to do ??


Top
 Profile  
 
 Post subject: Re: PHP 5.3 requires MySQL 5.1?
Unread postPosted: Mon Oct 24, 2011 6:20 pm 
Offline
Long Time Forum Regular
Long Time Forum Regular

Joined: Sat Aug 20, 2005 9:30 am
Posts: 2812
Location: The Netherlands
Don't exclude mysql*, because that also excludes the mysqlclient16 package that you need. You might want to do something like exclude=mysql mysql-libs mysql-server instead.

_________________
Lemonbit Internet Dedicated Server Management


Top
 Profile  
 
 Post subject: Re: PHP 5.3 requires MySQL 5.1?
Unread postPosted: Tue Oct 25, 2011 6:23 am 
Offline
New Forum User
New Forum User

Joined: Wed Oct 12, 2011 4:06 pm
Posts: 3
Location: Netherlands
Many thanks.
All works now. PHP upgraded to 5.3.8 and MySQL still 5.0.77
I only needed to replace exclude=mysql* with: exclude=mysql-*
to make sure that mysqlclient16 was not excluded.


Top
 Profile  
 
 Post subject: Re: PHP 5.3 requires MySQL 5.1?
Unread postPosted: Sun Oct 30, 2011 6:06 am 
Offline
Forum User
Forum User

Joined: Mon Jun 14, 2010 8:39 pm
Posts: 18
I am having a similar problem and I do not have any excludes. I just want to update to the latest but, this error is stopping me. Any ideas?

Setting up Update Process
Resolving Dependencies
--> Running transaction check
---> Package mysql.x86_64 0:5.5.17-2.el5.art set to be updated
--> Processing Dependency: libmysqlclient.so.16 for package: php-mysql
--> Processing Dependency: libmysqlclient.so.16(libmysqlclient_16) for package: php-mysql
--> Processing Dependency: libmysqlclient.so.16()(64bit) for package: ossec-hids-server
--> Processing Dependency: libmysqlclient.so.16()(64bit) for package: php-mysql
--> Processing Dependency: libmysqlclient.so.16(libmysqlclient_16)(64bit) for package: ossec-hids-server
--> Processing Dependency: libmysqlclient.so.16(libmysqlclient_16)(64bit) for package: php-mysql
---> Package mysql-libs.i386 0:5.5.17-2.el5.art set to be updated
---> Package mysql-libs.x86_64 0:5.5.17-2.el5.art set to be updated
---> Package mysql-server.x86_64 0:5.5.17-2.el5.art set to be updated
--> Running transaction check
--> Processing Dependency: libmysqlclient.so.16 for package: php-mysql
--> Processing Dependency: libmysqlclient.so.16(libmysqlclient_16) for package: php-mysql
---> Package mysqlclient16.x86_64 0:5.1.59-1.el5.art set to be updated
--> Finished Dependency Resolution
php-mysql-5.3.8-1.el5.art.i386 from installed has depsolving problems
--> Missing Dependency: libmysqlclient.so.16(libmysqlclient_16) is needed by package php-mysql-5.3.8-1.el5.art.i386 (installed)
php-mysql-5.3.8-1.el5.art.i386 from installed has depsolving problems
--> Missing Dependency: libmysqlclient.so.16 is needed by package php-mysql-5.3.8-1.el5.art.i386 (installed)
Error: Missing Dependency: libmysqlclient.so.16(libmysqlclient_16) is needed by package php-mysql-5.3.8-1.el5.art.i386 (installed)
Error: Missing Dependency: libmysqlclient.so.16 is needed by package php-mysql-5.3.8-1.el5.art.i386 (installed)


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 7 posts ] 

» Feed - Atomicorp

All times are UTC - 5 hours [ DST ]


Who is online

Users browsing this forum: Yahoo [Bot] and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group